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Input Ouput Description 

df <- read.table(‘file.txt’) write.table(df, ‘file.txt’) Read and write a delimited text 
file.

df <- read.csv(‘file.csv’) write.csv(df, ‘file.csv’)

Read and write a comma 
separated value file. This is a 

special case of read.table/
write.table. 

load(‘file.RData’) save(df, file = ’file.Rdata’) Read and write an R data file, a 
file type special for R. 

?mean  
Get help of a particular function. 
help.search(‘weighted mean’) 
Search the help files for a word or phrase. 
help(package = ‘dplyr’) 
Find help for a package. 

Getting Help
Accessing the help files

More about an object

str(iris) 
Get a summary of an object’s structure.  
class(iris) 
Find the class an object belongs to.

Programming
For Loop

for (variable in sequence){ 

Do something 

}

Example
for (i in 1:4){ 

j <- i + 10 

print(j) 

}

While Loop

while (condition){ 

Do something 

}

Example
while (i < 5){ 

print(i) 

i <- i + 1 

}

If Statements

if (condition){ 
Do something 

} else { 
Do something different  

}

Example
if (i > 3){ 

print(‘Yes’) 
} else { 

print(‘No’)  
}

Functions
function_name <- function(var){ 

Do something 

return(new_variable) 
}

Example
square <- function(x){ 

squared <- x*x 

return(squared) 
}

a == b Are equal a > b Greater than a >= b Greater than 
or equal to is.na(a) Is missing

a != b Not equal a < b Less than a <= b Less than or 
equal to

is.null(a) Is null 
Conditions

Creating Vectors

c(2, 4, 6) 2 4 6 Join elements into 
a vector 

2:6 2 3 4 5 6 An integer 
sequence

seq(2, 3, by=0.5) 2.0 2.5 3.0 A complex 
sequence

rep(1:2, times=3) 1 2 1 2 1 2 Repeat a vector

rep(1:2, each=3) 1 1 1 2 2 2 Repeat elements 
of a vector 

install.packages(‘dplyr’) 
Download and install a package from CRAN. 

library(dplyr)  
Load the package into the session, making all 
its functions available to use.  

dplyr::select  
Use a particular function from a package. 

data(iris) 
Load a built-in dataset into the environment. 

Using Packages

Vectors

Selecting Vector Elements 

x[4] The fourth element.

x[-4] All but the fourth.

x[2:4] Elements two to four.

x[-(2:4)] All elements except 
two to four.

x[c(1, 5)] Elements one and 
five.

x[x == 10] Elements which 
are equal to 10.

x[x < 0] All elements less 
than zero.

x[x %in%  
c(1, 2, 5)]

Elements in the set 
1, 2, 5.

By Position

By Value

Named Vectors 

x[‘apple’] Element with 
name ‘apple’.

Reading and Writing Data

Working Directory
getwd() 
Find the current working directory (where 
inputs are found and outputs are sent). 

setwd(‘C://file/path’) 
Change the current working directory. 

Use projects in RStudio to set the working  
directory to the folder you are working in.  

Vector Functions
sort(x)  
Return x sorted.

rev(x)  
Return x reversed.

table(x)  
See counts of values.

unique(x)  
See unique values.

Also see the readr package.
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Lists

Matrices

Data Frames

Maths Functions 

Types Strings 

Factors 

Statistics 

Distributions 

as.logical TRUE, FALSE, TRUE Boolean values (TRUE or FALSE).

as.numeric 1, 0, 1 Integers or floating point 
numbers.

as.character '1', '0', '1' Character strings. Generally 
preferred to factors.

as.factor
'1', '0', '1', 
levels: '1', '0'

Character strings with preset 
levels. Needed for some 

statistical models. 

Converting between common data types in R. Can always go 
from a higher value in the table to a lower value. 

> a <- 'apple' 
> a 
[1] 'apple'

The Environment

Variable Assignment

ls() List all variables in the 
environment.

rm(x) Remove x from the 
environment.

rm(list = ls()) Remove all variables from the 
environment.

You can use the environment panel in RStudio to 
browse variables in your environment. 

factor(x) 
Turn a vector into a factor. Can 
set the levels of the factor and 

the order.

m <- matrix(x, nrow = 3, ncol = 3) 
 Create a matrix from x.

wwwwww
m[2,  ] - Select a row

m[ , 1] - Select a  column

m[2, 3] -  Select an elementwwwwww
wwwwww

t(m) 
Transpose 
m %*% n 

Matrix Multiplication 
solve(m, n) 

Find x in: m * x = n

l <- list(x = 1:5, y = c('a', 'b')) 
 A list is a collection of elements which can be of different types. 

l[[2]] l[1] l$x l['y']

Second element 
of l.

New list with 
only the first 

element.

Element named 
x.

New list with 
only element 

named y.

df <- data.frame(x = 1:3, y = c('a', 'b', 'c')) 
A special case of a list where all elements are the same length.

t.test(x, y) 
Perform a t-test for 
difference between 

means. 

pairwise.t.test 
 Perform a t-test for 

 paired data.

log(x) Natural log. sum(x) Sum.

exp(x) Exponential. mean(x) Mean.

max(x) Largest element. median(x) Median. 

min(x) Smallest element. quantile(x) Percentage 
quantiles.

round(x, n) Round to n decimal 
places.

rank(x) Rank of elements.

signif(x, n) Round to n 
significant figures.

var(x) The variance.

cor(x, y) Correlation. sd(x) The standard 
deviation.

x y

1 a

2 b

3 c

Matrix subsetting

df[2, ]

df[ , 2]

df[2, 2]

List subsetting

df$x df[[2]]

cbind - Bind columns.

rbind - Bind rows.

View(df) See the full data 
frame.

head(df) See the first 6 
rows.

Understanding a data frame

nrow(df) 
Number of rows. 

ncol(df) 
Number of 
columns. 

dim(df) 
Number of 
columns and 
rows.

Plotting  

Dates See the lubridate package.

Also see the ggplot2 package.

Also see the stringr package.

Also see the 
dplyr package.

plot(x) 
Values of x in 

order.

plot(x, y) 
Values of x 
against y.

hist(x) 
Histogram of 

x.

Random 
Variates 

Density 
Function

Cumulative 
Distribution

Quantile

Normal rnorm dnorm pnorm qnorm

Poisson rpois dpois ppois qpois

Binomial rbinom dbinom pbinom qbinom

Uniform runif dunif punif qunif

lm(y ~ x, data=df) 
Linear model. 

glm(y ~ x, data=df) 
Generalised linear model. 

summary 
Get more detailed information 

 out a model.

prop.test 
Test for a 
difference 
between 

proportions. 

aov 
Analysis of 
variance. 

paste(x, y, sep = ' ') Join multiple vectors together.

paste(x, collapse = ' ') Join elements of a vector together.

grep(pattern, x) Find regular expression matches in x. 

gsub(pattern, replace, x) Replace matches in x with a string.

toupper(x) Convert to uppercase.

tolower(x) Convert to lowercase.

nchar(x) Number of characters in a string. 

cut(x, breaks = 4) 
Turn a numeric vector into a 

factor by ‘cutting’ into 
sections.  
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Search inside 
environment

Syntax highlighting based 
on your file's extension

Code diagnostics that appear in the margin. 
Hover over diagnostic symbols for details.

Tab completion to finish function 
names, file paths, arguments, and more.

Multi-language code snippets to 
quickly use common blocks of code.

Open in new 
window

Save Find and 
replace

Compile as 
notebook

Run 
selected 
code

Re-run 
previous code

Source with or  
w/out Echo or  
as a Local Job

Show file 
outline

Jump to function in file Change file type

Navigate 
backwards/
forwards

A File browser keyed to your working directory. 
Click on file or directory name to open.

Path to displayed directory

Create 
folder

Delete 
file 

Rename 
file 

Change  
directory

Displays saved objects by 
type with short description

View function 
source code

View in data 
viewer

Load 
workspace

Save 
workspace

Import data 
with wizard

Clear R 
workspace

Display objects 
as list or grid

Choose environment to display from 
list of parent environments

History of past 
commands to 
run/copy

Manage 
external 
databases

Working 
Directory

Maximize, 
minimize panes

Drag pane 
boundaries

Multiple cursors/column selection 
with Alt + mouse drag.

R tutorials

Ctrl/Cmd + a 
to see history

More file 
options
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RStudio opens plots in a dedicated Plots pane

Navigate 
recent plots

Open in 
window

Export 
plot

Delete 
plot

Delete 
all plots

RStudio opens documentation in a dedicated Help pane

Home page of 
helpful links 

Search within 
help file

Search for 
help file

Viewer pane displays HTML content, such as Shiny 
apps, RMarkdown reports, and interactive visualizations

Stop Shiny 
app

Publish to shinyapps.io, 
rpubs, RSConnect, …

Refresh 

Tab Panes
Open Shiny, R Markdown, 
knitr, Sweave, LaTeX, .Rd files 
and more in Source Pane

RStudio recognizes that files named app.R, 
server.R, ui.R, and global.R belong to a shiny app

Run 
app

Choose 
location to 
view app

Publish to 
shinyapps.io 
or server

Manage 
publish 
accounts

Documents and Apps

Access markdown guide at 

Help > Markdown Quick Reference 
See reverse side for more on Visual Editor

Check 
spelling

Render 
output

Choose 
output 
format

Configure 
render 
options

Insert 
code 
chunk

Jump to 
previous 
chunk

Jump 
to next 
chunk

Run 
code

Publish 
to server

Show file 
outline

Set knitr 
chunk 
options

Run this and 
all previous 
code chunks

Run this 
code chunkJump to 

section 
or chunk

Visual 
Editor 
(reverse 
side)

GUI Package manager lists every installed package

Click to load package with 
library(). Unclick to detach 
package with detach().

Delete 
from 
library

Install 
Packages

Update 
Packages

Package 
version 
installed

Browse 
package site

View(<data>) opens spreadsheet like view of data set

Sort by 
values

Filter rows by value 
or value range

Search 
for value

Turn on at Tools > Project Options > Git/SVN
• Added

• Deleted


• Modified

• Renamed
 • Untracked

A

D

M

R
?

Stage 
files:

Show file diff to view file differences

Current 
branch

Commit 
staged files

Push/Pull  
to remote

View 
History

Open shell to type commands

Version

Control

Package Development

Roxygen guide at Help > Roxygen Quick Reference 


See package information in the Build Tab

Create a new package with 
File > New Project > New Directory > R Package

Enable roxygen documentation with 
Tools > Project Options > Build Tools

Install package 
and restart R

Run R CMD 
check

Run devtools::load_all() 
and reload changes

Customize 
package build 
options

Run 
package 
tests

Clear output 
and rebuild

Use debug(), browser(), or a breakpoint and execute 
your code to open the debugger mode.

Debug Mode

Examine variables 
in executing 
environment

Click next to line number to 
add/remove a breakpoint.

Select function 
in traceback to 
debug

Highlighted line shows where 
execution has paused

Run commands in 
environment where 
execution has paused

Step through 
code one line 
at a time

Step into and 
out of functions 
to run

Resume 
execution

Quit debug 
mode

Open traceback to examine 
the functions that R called 
before the error occurred

Launch debugger 
mode from origin 
of error

View 
memory 
usage

R Markdown 
Build Log

Run scripts in 
separate sessions
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RUN CODE Windows/Linux Mac
Search command history Ctrl+a Cmd+a
Interrupt current command Esc Esc
Clear console Ctrl+L Ctrl+L

NAVIGATE CODE
Go to File/Function Ctrl+. Ctrl+.

WRITE CODE
Attempt completion Tab or 

Ctrl+Space
Tab or  
    Ctrl+Space

Insert <- (assignment operator) Alt+- Option+-
Insert %>% (pipe operator) Ctrl+Shift+M Cmd+Shift+M
(Un)Comment selection Ctrl+Shift+C Cmd+Shift+C

MAKE PACKAGES Windows/Linux Mac
Load All (devtools) Ctrl+Shift+L Cmd+Shift+L
Test Package (Desktop) Ctrl+Shift+T Cmd+Shift+T
Document Package Ctrl+Shift+D Cmd+Shift+D

RStudio® is a trademark of RStudio, PBC  •  CC BY SA  RStudio  •  info@rstudio.com  •  844-448-1212  •  rstudio.com  •  Learn more at rstudio.com  •  Font Awesome 5.15.3  •  RStudio IDE  1.4.1717  •  Updated:  2021-07

Extend the open source server with a  
commercial license, support, and more:

• open and run multiple R sessions at once

• tune your resources to improve performance

• administrative tools for managing user sessions

• collaborate real-time with others in shared projects

• switch easily from one version of R to a different version

• integrate with your authentication, authorization, and audit practices

• work in the RStudio IDE, JupyterLab, Jupyter Notebooks, or VS Code

Download a free 45 day evaluation at 

www.rstudio.com/products/workbench/evaluation/ 

WHY RSTUDIO WORKBENCH?

Keyboard Shortcuts
DOCUMENTS AND APPS
Knit Document (knitr) Ctrl+Shift+K Cmd+Shift+K
Insert chunk (Sweave & Knitr) Ctrl+Alt+I Cmd+Option+I
Run from start to current line Ctrl+Alt+B Cmd+Option+B

MORE KEYBOARD SHORTCUTS
Keyboard Shortcuts Help Alt+Shift+K Option+Shift+K
Show Command Palette Ctrl+Shift+P Cmd+Shift+P

RStudio 

Workbench

Visual Editor

Share Projects

Share Project 
with Collaborators

Active shared 
collaborators

Select 

R Version

Start new R Session 
in current  project 

Close R Session 
in project 

JHT

Name of 
current 
project

RStudio saves the call history, 
workspace, and working 
directory associated with a 
project. It reloads each when 
you re-open a project. 

File > New Project

Check 
spelling

Render 
output

Choose 
output 
format

Choose 
output 
location

Insert 
code 
chunk

Jump to 
previous 
chunk

Jump 
to next 
chunk

Run 
selected 
lines

Publish 
to server

Show file 
outline

Set knitr 
chunk 
options

Run this and 
all previous 
code chunks

Run this 
code chunk

Back to 
Source Editor 
(front page)

File outline

Jump to chunk 
or header

Add/Edit 
attributes

Block 
format

Insert 
verbatim 
code

Clear 
formatting

Lists and 
block 
quotes

Links Citations Images

More 
formatting

Insert blocks, 
citations, 
equations, and 
special 
characters

Insert and 
edit tables

Search for keyboard shortcuts with 
Tools > Show Command Palette 
or Ctrl/Cmd + Shift + P.

View the Keyboard Shortcut Quick 
Reference with Tools > Keyboard 
Shortcuts or Alt/Option + Shift + K

Run Remote Jobs
Run R on remote clusters 
(Kubernetes/Slurm) via the 
Job Launcher

Launch a jobMonitor 
launcher jobs

Run launcher 
jobs remotely
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